Home > Hplip Error > Hplip Error Cannot Find Libcups Support

Hplip Error Cannot Find Libcups Support

checking for cupsDoFileRequest in -lcups... no configure: error: cannot find libcups support my configure command: [[email protected] hplip-2.8.7]# ./configure --enable-network-build --disable-pp-build --enable-fax-build --enable-dbus-build --enable-gui-build --enable-scan-build --enable-doc-build --enable-foomatic-ppd-install --disable-foomatic-drv-install --with-hpppddir=/usr/share/cups/model/hplip-ppds --disable-hpijs-only-build --libdir=/usr/lib64 --prefix=/usr Dell PowerEdger 2950-3, RHEL v5 (64bit) hp-check output: HP Linux Imaging and Printing System (ver. 1.6.7) Dependency/Version Check Utility ver. 2.1 Copyright (c) 2003-6 Hewlett-Packard Development Company, LP This software comes with ABSOLUTELY NO WARRANTY. This is free software, and you are welcome to distribute it under certain conditions. See COPYING file for more details. Basic system info... --> Linux momus.ssww.com 2.6.18-92.1.10.el5 #1 SMP Wed Jul 23 03:56:11 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux Currently installed version... --> 1.6.7 Checking Python version... --> Version 2.4.3 installed. --> OK Checking for user interface dependencies... Checking for SIP... --> OK Checking for PyQt... --> OK Checking Qt version... --> Version 3.3.6 installed. --> OK Checking SIP version... --> Version 4.4.5 installed --> OK Checking PyQt version... --> Version 3.16.0 installed. --> OK Checking for library dependencies... Checking for libnetsnmp... --> OK Checking for libjpeg... --> OK Checking for libusb... --> OK Checking for libcrypto... --> OK Checking for libpthread... --> OK Checking for application dependencies... Checking ghostscript... --> Version 8.15.2 Checking gcc... --> gcc (GCC) 4.1.2 20071124 (Red Hat 4.1.2-42) --> OK Checking make... --> GNU Make 3.81 --> OK Checking ReportLab (optional)... warni

issue and hplip 3.10.6 General support questions including new installations Post Reply Print view Search Advanced search 16 posts 1 2 Next r0cket Posts: 14 Joined: 2011/01/01 21:16:43 [SOLVED] network printer issue and hplip 3.10.6 Quote Postby r0cket » 2011/01/13 05:00:31 I'm trying to install https://answers.launchpad.net/hplip/+question/45531 hp DeskJet 6500 printer on a network. My Centos version isLinux xxxxx 2.6.18-194.26.1.el5xen #1 SMP Tue Nov 9 13:35:30 EST 2010 x86_64 x86_64 x86_64 GNU/LinuxOfcourse My printer model is not showing up on the list of printer list when using ipp http://www.centos.org/forums/viewtopic.php?t=16790 based configuration.so while searching around, I came across article to install hplip at http://home.roadrunner.com/~computertaijutsu/hplip.htmland I tried to install the following hplip version with centos.http://sourceforge.net/projects/hplip/f ... ip/3.10.6/Running the configure with following arguments./configure --with-hpppddir=/usr/share/ppd/HP --libdir=/usr/lib64 --prefix=/usr --enable-qt4 --enable-doc-build --enable-cups-ppd-install --disable-foomatic-drv-install --disable-foomatic-ppd-install --disable-hpijs-install --disable-policykit --disable-cups-drv-install --enable-hpcups-install --enable-network-build --enable-dbus-build --enable-scan-build --enable-fax-buildI get following errorconfigure: error: cannot find net-snmp support (or --disable-network-build)But net-snmp is installed on my system, so, I tried with disable-network-build and tried to get around the problem, the next error I get ischecking for usb_init in -lusb... noconfigure: error: cannot find libusb supportAny ideas?Thanks Top scottro Forum Moderator Posts: 2215 Joined: 2007/09/03 21:18:09 Location: NYC Contact: Contact scottro Website Re: network printer issue and hplip 3.10.6 Quote Postby scottro » 2011/01/13 09:00:20 Unfortunat

Blogs Portal Calendar Easy URPMI Chat MandrivaUsers.org > General Help > Hardware Posting Guidelines View New Content Page 1 of 1 You cannot start a new topic You cannot reply to this topic HPLIP and new HP printers Why is the http://mandrivausers.org/index.php?/topic/70984-hplip-and-new-hp-printers/ repository always off by one rev? #1 banjo Awesome Group: Members Posts: 409 https://forums.mageia.org/en/viewtopic.php?t=2294&p=17334 Joined: 24-May 03 Posted 18 October 2008 - 01:18 AM Now that I have my new Mandy 2008.1 I am in the market for a color printer. I have installed HPLIP and plan on buying an HP printer. I had Epson printers before, and I will not by another one because they were nothing but a PIA. I hplip error spent more paper and ink cleaning their heads than I ever spent printing. I had two C-84s that died in the same way withing weeks of one another, and since it was the built-in print heads that died, the printers ended up in the trash. Anyway, I want a small all-in-one since I will use it rarely and I will also be replacing an old scanner with it. I do my heavy printing hplip error cannot on my Lexmark laser, but it is not a color printer. I looked online and came up with the HP 4280 as a possible option. A brief search of hplipopensource.com revealed that the 4200 series requires HPLIP 2.8.5, and my brand new Mandy 2008.1 has 2.8.2. :wall:/> I waited to replace the printer until I had the upgraded system so that I would have drivers for a new HP. But it seems that the repositories are always a couple of revs behind what is required for the printers that are still on the shelves. So here are my questions: Can I get a binary of a later HPLIP and just install it? Do I really have to build one from source code to upgrade? :wacko:/> Will the printer limp along with an older driver with partial function? Is there a better (more compatible) all-in-one printer to get? Drivers always throw me for a loop. Thanks in advance for anyone who can help. Banjo (_)=='=~ This post has been edited by banjo: 18 October 2008 - 01:19 AM If only the best bird sang the forest would be a very quiet place. 0 Back to top MultiQuote Reply #2 ianw1974 Platinum Group: Admin Posts: 14,079 Joined: 09-March 05 Posted 18 October 2008 - 03:53 PM Well, M

help and support :Ask here your questions about advanced usage of Mageia. For example you may post here all your questions about network and automated installs, complex server configurations, kernel tuning, creating your own Mageia mirrors, and all tasks likely to be touchy even for skilled users. Post a reply 15 posts • Page 1 of 1 hplip install v3.12.4 from hp: help! by tonyb » Apr 24th, '12, 12:30 Mageia2 beta 3 x89_64Needed 3.12.4 for my Hp officejet pro 8600 plus.1. downloaded source from hp2. used to following from an hp 'mandriva 2010.0 and above' howto:su - -c "urpmi --allow-force --force --auto cups cups-common libcups2-devel libcups2 libdbus-1-devel python-gobject gcc-c++ ghostscript libopenssl0.9.8-devel libjpeg-devel libnet-snmp-devel glibc-i18ndata glibc_lsb libtool libgphoto-devel libusb1.0-devel make python-imaging policykit policykit-gnome python-qt4 qt4-qtdbus python-dbus libpython2.6-devel python python-reportlab saned libsane1-devel sane-backends libsane1 xsane sane-frontends"later in that script, used:64 bit distro users:./configure --with-hpppddir=/usr/share/ppd/HP --libdir=/usr/lib64 --prefix=/usr --enable-qt4 --enable-doc-build --disable-cups-ppd-install --disable-foomatic-drv-install --disable-foomatic-ppd-install --disable-hpijs-install --disable-policykit --enable-cups-drv-install --enable-hpcups-install --enable-network-build --enable-dbus-build --enable-scan-build --enable-fax-buildget most of the way there, then:checking for net-snmp/net-snmp-config.h... yeschecking for cupsDoFileRequest in -lcups... noconfigure: error: cannot find libcups supportpackage seems to be there:# urpmi libcups2Package libcups2-1.5.2-3.mga2.i586 is already installedThought it wanted the 64 bit lib, installed it:# urpmi lib64cups2Package lib64cups2-1.5.2-3.mga2.x86_64 is already installedThis process worked on mageia1, don't know why its failing in m2beta3. Ideas? tonyb Posts: 16Joined: May 1st, '11, 03:54 Top Re: hplip install v3.12.4 from hp: help! by djennings » Apr 24th, '12, 13:25 You need the devel packagelib64cups2-devel djennings Posts: 613Joined: Jun 2nd, '11, 23:51Location: Wokingham, UK Top Re: hplip install v3.12.4 from hp: help! by tonyb » Apr 26th, '12, 11:41 installled it at some point:# urpmi lib64cups2-develPackage lib64cups2-devel

 

hplip error python gobject/dbus may be not installed

Hplip Error Python Gobject dbus May Be Not Installed p duplicate of Bug pkservice py crashed with AttributeError in init 'module' object has no attribute 'MainLoop' Edit Remove This bug affects people Affects Status Importance Assigned to Milestone HPLIP Edit Confirmed Undecided Unassigned Edit One Hundred Papercuts Edit Confirmed Medium Unassigned Edit hplip Ubuntu Edit Confirmed Medium Unassigned Edit Also affects project Also affects distribution package Nominate for series Bug Description When trying to configure an HP LaserJet P w when running hp-plugin I get errors and can not proceed nessita miro hp-plugin error Unable to locate models dat file